Missing Data when Restored

Have questions about Backup4all, or having problems using it? Ask here for help.
Post Reply
neil CBE
Posts: 5
Joined: Thu Oct 08, 2020 10:39 pm

Missing Data when Restored

Post by neil CBE »

I have always backed up a Data Base program with 1000's of records which has worked perfectly for years.
Now when I restore and run the backup, the program works fine but many records after a randomised date are missing.
I do a Full Backup with normal compression, no encryption and tried with and without testing.
I'm running the latest version of Backup4all.
Any ideas would be very welcome.

Adrian (Softland)
Posts: 1902
Joined: Wed Dec 16, 2009 12:46 pm

Re: Missing Data when Restored

Post by Adrian (Softland) »

Hi,

In the Restore Wizard did not select "Restore excluded and deleted files" option?
Do you know you can monitor your backups remotely with Backup4all Monitor? You can read more here: https://www.backup4all.com/backup4all-monitor.html

neil CBE
Posts: 5
Joined: Thu Oct 08, 2020 10:39 pm

Re: Missing Data when Restored

Post by neil CBE »

Hi Adrian
Because its backing up a live Data Base on a Server I don't use the restore function, we just copy and paste the complete backed up folder into a test data base. I've further tested backing up to an alternative network location and it restores and works perfect.

This is therefore a problem with our network but we cant understand why. It is only restoring data files up to 27th of July despite copying the folder from the most recent backup. Its as though every backup we make is copying a previous backup from 27th. Very strange.

Adrian (Softland)
Posts: 1902
Joined: Wed Dec 16, 2009 12:46 pm

Re: Missing Data when Restored

Post by Adrian (Softland) »

Hi,

Please restart the Volume Shadow Copy Service of Windows, from Control Panel->Administrative Tools->Services.
That service is used to back up open files.
Then run again the backup and see if the same old data is backed up.
Do you know you can monitor your backups remotely with Backup4all Monitor? You can read more here: https://www.backup4all.com/backup4all-monitor.html

neil CBE
Posts: 5
Joined: Thu Oct 08, 2020 10:39 pm

Re: Missing Data when Restored

Post by neil CBE »

Hi Adrian
That seems to have cured it, thanks.

Is there a logical explanation of what it's doing and what might be causing it. The biggest problem is that it doesn't throw up any errors and there is no way to tell if the backup is current without restoring.

Adrian (Softland)
Posts: 1902
Joined: Wed Dec 16, 2009 12:46 pm

Re: Missing Data when Restored

Post by Adrian (Softland) »

Hi,

I don't know why that happened, it should be Microsoft helping you with the Volume Shadow Copy service, as the service is from Windows. Backup4all only asks that service to provide a copy of the open files.
Do you know you can monitor your backups remotely with Backup4all Monitor? You can read more here: https://www.backup4all.com/backup4all-monitor.html

Post Reply