Invalid argument to date encode

Have questions about Backup4all, or having problems using it? Ask here for help.
Post Reply
pcready.cl
Posts: 17
Joined: Wed Jan 13, 2016 12:44 am

Invalid argument to date encode

Post by pcready.cl »

I have several Backup4all version 7.x and 8.x working and from today I get the following error:

"Invalid argument to date encode"

I need help
Attachments
AGSSOFT-SQL_REMOTO_20200228221800.backup.log.zip
(3.42 KiB) Downloaded 151 times

pcready.cl
Posts: 17
Joined: Wed Jan 13, 2016 12:44 am

Re: Invalid argument to date encode

Post by pcready.cl »

v8.4
Attachments
BACKUP4ALL-REMOTO_20200229001115.backup.log.zip
(3.39 KiB) Downloaded 139 times

Adrian (Softland)
Posts: 1710
Joined: Wed Dec 16, 2009 12:46 pm

Re: Invalid argument to date encode

Post by Adrian (Softland) »

Hi,

Please write us an email to support[at]backup4all[dot]com about this issue, to create us a temporary account on your FTP server, so we can reproduce the problem.

pcready.cl
Posts: 17
Joined: Wed Jan 13, 2016 12:44 am

Re: Invalid argument to date encode

Post by pcready.cl »

Same problem with v9.x...

[code][21-06-2021 18:33:11] Connecting to SFTP server SERVER:PORT
[21-06-2021 18:33:12] OpenSSH_8.2p1
[21-06-2021 18:33:12] Checking backup destination (SFTP server)
[21-06-2021 18:33:12] Opening file "C:\Users\servags-bk\AppData\Roaming\Softland\Backup4all 9\Catalogs\BACKUP4ALL_REMOTO(2).bkc"
[21-06-2021 18:33:12] Opening file "C:\Users\servags-bk\AppData\Roaming\Softland\Backup4all 9\Catalogs\BACKUP4ALL_REMOTO(2).bkc"
[21-06-2021 18:33:13] Checking if the drives of the sources exist
[21-06-2021 18:33:13] Opening file ":memory:"
[21-06-2021 18:33:13] Creating the list of files to backup
[21-06-2021 18:33:13] Folders found to backup: 7
[21-06-2021 18:33:13] Files found to backup: 38 (97,23 MB)

[21-06-2021 18:33:13] Preparing shadow copy
[21-06-2021 18:33:43] Shadow copy created for drives C:\
[21-06-2021 18:33:45] Opening file ":memory:"

[21-06-2021 18:33:45] Archiving files to 2021-06-21_.1_Backup4all Configurations.zip
[21-06-2021 18:33:46] Warning: Skipping all files and folders from drive "//Backup4all Configurations//". Invalid argument to date encode
Backup aborted. Reason:
All the files and folders have been skipped. Nothing to backup.
Next scheduled backup: Not scheduled
Backup aborted after 36 second(s) at 21-06-2021 18:33:46 with 1 error(s), 1 warning(s)
[21-06-2021 18:33:46] Sending mail to "EMAIL"
[21-06-2021 18:33:52] Error: All the files and folders have been skipped. Nothing to backup.[/code]

Adrian (Softland)
Posts: 1710
Joined: Wed Dec 16, 2009 12:46 pm

Re: Invalid argument to date encode

Post by Adrian (Softland) »

Hi,

I created a ticket for this problem and we will fix it.

Jim Simpson
Posts: 2
Joined: Thu Jun 24, 2021 4:45 pm

Re: Invalid argument to date encode

Post by Jim Simpson »

Is there any way around this problem, so we can get files backed up?

Adrian (Softland)
Posts: 1710
Joined: Wed Dec 16, 2009 12:46 pm

Re: Invalid argument to date encode

Post by Adrian (Softland) »

Hi,

The problem was fixed in build 9.0.333.
Please download and install it.
If you have any other problems, please let us know.

Jim Simpson
Posts: 2
Joined: Thu Jun 24, 2021 4:45 pm

Re: Invalid argument to date encode

Post by Jim Simpson »

Thanks, Adrian. It works perfectly now.

Post Reply