Custom S3 configuration not saved to .ini file

Have questions about Backup4all, or having problems using it? Ask here for help.
Post Reply
rshriot
Posts: 1
Joined: Mon Mar 04, 2024 7:51 pm

Custom S3 configuration not saved to .ini file

Post by rshriot »

On build 9.9.855 on Windows, trying to use Wasabi as a destination.

Edit a job. Under Destination, select S3 Compatible and edit configuration. Make some changes (endpoint, etc). Click Ok and Save to complete the job edit. Note that the job's destination has correctly updated in the UI. Re-enter the edit job dialog or re-launch the program to discover that all of your changes have been lost.

The same behavior is exhibited when using the Wasabi presets to set the endpoints. Or using a saved Wasabi destination.

I've been able to manually run jobs by setting all of the values myself in the .ini files
AWS_ACCESS_KEY_COMPAT=
AWS_SECRET_KEY_COMPAT=
AWS_BUCKET_COMPAT=
AWS_ENDPOINT_COMPAT=
and then starting the program, but those values get to their defaults any time the program updates the .ini files for any reason.

Could this be a reversion of the "Fixed: Custom S3 Endpoints were not saved in some specific cases" in 9.0.317?

Adrian (Softland)
Posts: 1936
Joined: Wed Dec 16, 2009 12:46 pm

Re: Custom S3 configuration not saved to .ini file

Post by Adrian (Softland) »

Hi,

I could not reproduce the problem here. Editing the backup destination of such a job, will preserve all other information.
Do you know you can monitor your backups remotely with Backup4all Monitor? You can read more here: https://www.backup4all.com/backup4all-monitor.html

Post Reply