Windows cannot read from disk

Have questions about Backup4all, or having problems using it? Ask here for help.
Post Reply
Posts: 3
Joined: Wed Mar 06, 2013 9:03 pm

Windows cannot read from disk

Post by julian »

Hi Support,

We cant browse or explore Bluray BD-RE media after a successful backup in Windows Explorer.
We also get an error when we tick “test after backup” that states the media is not available.

We used Ridata BD-RE disks and also tried Verbatim BD-R disks and get the same error in windows when trying to explore the disk after a successful backup.

We us a “LG HL-DT-ST BD-RE BH10LS30 1.00” Bluray Writer in a external USB carriage.
We used it for over a year without any problems with media or to restore. The media is brand new.
It gives the same error on any media when trying to browse it in windows to access the .zip files on the disk.

The error pops up in windows “ Windows cannot read from disk. The disk might be corrupted, or it could be using a format that is not compatible with Windows”

Adrian (Softland)
Posts: 1876
Joined: Wed Dec 16, 2009 12:46 pm

Re: Windows cannot read from disk

Post by Adrian (Softland) »


In Tools->Options->CD, DVD or Blu-ray, is the SPTD or SPTI burner selected?
Have you tried to install the new firmware for that device?

Post Reply