Restoring Backup4All configuration on new laptop

Have questions about Backup4all, or having problems using it? Ask here for help.
Post Reply
Rebeccah
Posts: 15
Joined: Wed May 12, 2010 4:23 am

Restoring Backup4All configuration on new laptop

Post by Rebeccah » Thu Jan 28, 2016 4:35 am

I just got a new laptop at work. I have Windows 7 32-bit on the old one, and Windows 7 64-bit on the new one. On the old laptop, I have Backup4all 5.2, build 632. On my new laptop, I have version 5.5, build 839.

I created a backup job for the backup4all setting on the old laptop, and backed up to a folder on a network share mapped to my W: drive, with the backup catalog stored with the backup files. Now I'm trying to restore.

I've created the same network share on my new laptop, and I've told Windows where to find the Backup4all.exe (in the x86 Program Files), but I get the following error message when I try to open the file:
"Invalid parameters."

Is this due to the 32-bit vs 64-bit, or due to the Backup4all version difference, or something else? Is there a work-around?

Thanks,

Rebeccah

Rebeccah
Posts: 15
Joined: Wed May 12, 2010 4:23 am

Re: Restoring Backup4All configuration on new laptop

Post by Rebeccah » Thu Jan 28, 2016 5:10 am

Hunh.

That will teach me to read the fine directions.

If I go inside Backup4all and click "open", I see the folder that has the backup catalog in it, and when I click on that, the job definition is recreated. The test looks fine. Now I'm about to restore.

But I'm not sure what to put for the location, since Backup4all in 64-bit Windows is installed to a different location from Backup4all in 32-bit Windows. If I open up the job on my old laptop, I see the locations are given as <descriptor> entries, rather than as actual file locations. Can I trust the instance on the new laptop to know where those are on the local system?

It looks to me like the job configuration files are in C:\Users\<me>\AppData\Roaming\Softland\Backup4all 5 on both PCs, so I'm going to go for it and say to restore to the same location...

Rebeccah

Support
Posts: 1491
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Restoring Backup4All configuration on new laptop

Post by Support » Thu Jan 28, 2016 8:59 am

Hi,

You should restore in the original location.
Please note: if you have different user names on the old and new computers and your Backup4all settings were per user, the restore might not work correctly.

Post Reply