Mirror backup issue

Have questions about Backup4all, or having problems using it? Ask here for help.
Post Reply
Cannathon
Posts: 6
Joined: Tue May 10, 2011 8:08 am

Mirror backup issue

Post by Cannathon »

Hello,

When I look at "Views > Backup" I see a proper mirror replication of my source data.
However, when I go to the target mirror backup folder and look at the data using the Windows explorer,
I do not see a proper replication. There I still can see "old folders" that were deleted or moved.

Why is this and is there a way to improve this?

Thanks,
Cannathon

Adrian (Softland)
Posts: 1550
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Mirror backup issue

Post by Adrian (Softland) »

Hi,

Yes, there is.

Open Backup Properties window for the backup job.
Go to Mirror page.
Set the "Remove excluded or deleted files from backup" option.
Set the "Only if the source drive is available" option.
Click Save to close window.

At next backup run, the deleted and moved files will be deleted from backup destination.

Cannathon
Posts: 6
Joined: Tue May 10, 2011 8:08 am

Re: Mirror backup issue

Post by Cannathon »

Hi,

Thanks for your reply!

I had already the "Remove excluded or deleted files from backup" option set.
In addition, I also set the "Only if the source drive is available" option but no change.
I still have have a lot of old empty folders in my target backup location. Files that were inside have been deleted but B4A does not get rid of the old empty folders.

Anything else I can try? Or is my backup job/catalog corrupt?

THX

Cannathon

Adrian (Softland)
Posts: 1550
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Mirror backup issue

Post by Adrian (Softland) »

Hi,

What version of Backup4all do you use?
What backup destination do you use?

Cannathon
Posts: 6
Joined: Tue May 10, 2011 8:08 am

Re: Mirror backup issue

Post by Cannathon »

Hello,

I am always using the latest build (currenlty version 4.5 build 243).

I am using B4A Pro on a Windows 7 Ultimate x64 machine.
The data is stored on a second internal HDD (SATA1) and backed up to a third internal HDD (SATA2).
OS and B4A are on the main HDD (SATA0).

Regards,

Cannahton

Adrian (Softland)
Posts: 1550
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Mirror backup issue

Post by Adrian (Softland) »

Hi,

The version you use is almost 3 months old.
The current version for May 25, 2011 is 4.6.253.
Please download it from our website and let us know if you still have the problem.

Cannathon
Posts: 6
Joined: Tue May 10, 2011 8:08 am

Re: Mirror backup issue

Post by Cannathon »

Ups...

I have upgraded to v.4.6.253 yesterday but it did not help.
Could it be the B4A catalog is not aware of those old empty folders in the backup target location?
As I said, when looking at the backup files/folders from the B4A GUI I don't see the old empty folders.
Don't think B4A is going to get it right again. Do I need to delete the job and recreate it? Or is it OK to
simply delete all files and folders in the backup destination folder?

Thanks,

Cannathon

Adrian (Softland)
Posts: 1550
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Mirror backup issue

Post by Adrian (Softland) »

Hi,

Manually deleting all files in destination is not a solution.
Please open Backup Properties->Advanced.
In the "Run action before backup" section check the "Run program or action" and "Run only one" options.
Press Save and run the backup.
All files from destination and the catalog will be deleted and a new backup will be created.

Post Reply