FTP and Linkstation - ***Resolved***

Have questions about Backup4all, or having problems using it? Ask here for help.
Post Reply
Posts: 16
Joined: Wed Oct 04, 2017 6:33 pm

FTP and Linkstation - ***Resolved***

Post by drc » Wed Oct 04, 2017 6:50 pm


I'm trying to get Backup4all v 6.6 build 388 to connect to my Buffalo linkstation LS220D. I'm 100% sure it's not the linkstation as i can connect to it with FileZilla.

I've set-up an FTP configuration under file>options>ftp using the same ip address as used in filezilla with the same user name and password (see attached) - all options other than the ip field, the destination folder and the uid/password are default.

However, when i try and test i get a 'Cannot connect to the ftp server' instantly. It's seems not to be even trying. Again, using filezilla gets me straight in. This is an internal home network and the ip address is internal.

If i look at the filezilla settings (attached) i note that the port is blank (not possible with backup4all) but all other settings are default for filezilla.

Can anyone guide me as to what I'm doing wrong? Thanks.
backupall filezilla settings.png
backupall filezilla settings.png (27.01 KiB) Viewed 47400 times
backup4all ftp config.png
backup4all ftp config.png (23.13 KiB) Viewed 47400 times
Last edited by drc on Wed Oct 25, 2017 9:40 am, edited 3 times in total.

Posts: 1503
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania

Re: FTP and Linkstation

Post by Support » Fri Oct 06, 2017 12:57 pm


In Backup4all, do not use http:// in the server name field. Use only the IP.
Let us know if you still have the problem.

Posts: 16
Joined: Wed Oct 04, 2017 6:33 pm

Re: FTP and Linkstation

Post by drc » Fri Oct 06, 2017 2:19 pm

I had said: "Bingo - many thanks!" but that was premature! I had been able to successfully test the FTP connection.

However, when i run the backup. I get a 'permission denied' error. From the error log: Cannot upload file "C:\Users\DRC\AppData\Local\Temp\Softland\Backup4all 6\7PSH1CU8H4203370\1_C.zip" to "/mnt/Array1/DRC_backup/testftp/1_C.zip" (FTP). 550 mnt: Permission denied

I know that password is correct as, with the ftp test, if i chcnge it to one which i know is wrong, the test fails.

This is using a very small test file so it's not a file size issue.

If i google the '550 mnt: Permission denied' error i'm told that the error means that the target upload directory does not exist and cannot be created. It seems that this error normally means a lack of permissions.

So it looks like the Linkstation is refusing permission to create the directory and/or upload the file. However, it's worth noting that, with the same user credentials, I can create the directory perfectly well using Filezilla and, even after I have created it (i.e. Filezilla shows it exists on the linkstation) I get exactly the same upload error.

I'm thinking it my be a Linkstation configuration issue so have posted on the Buffalo forum. But, if anyone on this forum with Linkstation experience has solved the issue please do post as I'm watching the threat. Likewise if/when I solve the issue I'll update this thread.

Posts: 16
Joined: Wed Oct 04, 2017 6:33 pm

Re: FTP and Linkstation - ***Resolved***

Post by drc » Wed Oct 25, 2017 9:47 am

Hi, I finally resolved this.

It was a Linkstation path issue. The path needs to be set as: /array1/SharedFTP/ where 'array1' is the default volume descriptor and, in this example, 'SharedFTP' is the target directory. My mistake had been to (i) us the prefix '/mnt/' which is apparently for a TeraStation not a Linkstation and (ii) then miss out the initial '/' before the array1.

I had also upgraded to Backup4all v7 but don't think that was pertinent.

Hope this helps someone at some stage.

Post Reply