Duplicate posts of daily backups

Have questions about Backup4all, or having problems using it? Ask here for help.
Post Reply
Standing Tall
Posts: 2
Joined: Sat Jul 14, 2012 6:22 pm

Duplicate posts of daily backups

Post by Standing Tall » Sat Jul 14, 2012 6:25 pm

Briefly, I've been a "tekkie" for some 12-15 years now, and have tried every backup program there is or has been on the market. I've never given up on Backup4All as I could tell that it's written very well. The proof of the pudding is that it works...especially when you need it the most in terms of restoring your system and its data files.

Here's the scenario of my current situation with running Backup4All v4.8.275 after upgrading from v4.6.261. BTW, I had used Revo Uninstaller to complete uninstall v4.6 before upgrading to v4.8, deleting all user activity, reg entries as well as the uninstall of the program itself. Furthermore, I removed all backup settings stored in another partition to preclude any potential problems. After that I used regedit to insure it was clean. Old habits die hard.

After the installation of v4.8.275, setting up of the individual jobs was a breeze (I've had a lot of practice); all 34 of them inside of just one group.

After scoping all of the preexisting errors posted in your forums over the last few months, I've yet to find anything close to my problem. I did notice that my install was setup for windows vista, when in fact I'm running Windows 7 Ultimate. I fixed that error quickly.

My problem is that Backup4all is creating duplicate postings whether they're full or differentials.
Many of the errors disappeared when I deleted the backup job as I discovered that using the "Date" tag will definitely mess me up good. Now all but 2 jobs are set up as a Differential, 3 backup limit with Merging activated. Clear archive bit is not activated.

When a backup creates #1 differential successfully, it then aborts in the process of creating the second differential with the following abbreviated transcript:
[7/14/2012 2:08:19 AM] Error: Backup aborted. Reason:
D:\Backup4all\Portable Apps\PortableApps.2_I.zip. The process cannot access the file because it is being used by another process
Backup aborted at 7/14/2012 2:08:19 AM with 1 error(s), 0 warning(s)

I have countless other samples; many of the jobs just simply created the second differential minutes on its own with no errors or warnings.

It really looks like my problem is not with Backup4all but its association with Windows7 task scheduler. The reason I say this is because IF I run the entire "Daily Backups" group from the systray, I never get any errors or warnings. Errors only happen within the early morning hours during the running of my (scheduled) single group. This has been the scenario for the past 5 consecutive days: cleaning out all duplicate entries; then running the group job on my own during the daytime hours. Its very frustrating but only takes approximately 20 minutes to run the entire group of 34 jobs.

In addressing the system's task scheduler I see 3 entries in its library:
Name Status Triggers
1) "b4a Daily Backups" Ready At 2:00AM Every Day
2) Backup4all OTB Agent Running At log on of Jim-PC\Jim
3) Backup4all Scheduler_Jim Running At log on of Jim-PC\Jim

My question is why do I need your built-in (#3) Backup4all Scheduler in a Running status when it should in my opinion be in a "Disbled" status as I don't use it. Naturally, I'm using Windows 7 task scheduler which works really well. And in Windows7 scheduler settings its configured to "Do not start a new instance."

And both the "Agent" as well as your internal Backup4all Scheduler both are configured for "Vista" while the Daily Backups as a group is configured for "Windows 7." Is that the problem.

BTW, I've checked my system as I run sfc /scannow from an elevated command prompt probably once or twice a week. Never an error.

In summary, even the best of software has its share of glitches or hick-ups, but your Backup4All has proven itself time and time again for several years now. It's still number #1 in my books.
I've learned from it, recommend it highly, and has saved my bacon on countless occasions.

Support
Posts: 1491
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Duplicate posts of daily backups

Post by Support » Tue Jul 17, 2012 11:57 am

Hi,

Does this situation happens no matter if you use the Windows scheduler or the Standalone scheduler?

Standing Tall
Posts: 2
Joined: Sat Jul 14, 2012 6:22 pm

Re: Duplicate posts of daily backups

Post by Standing Tall » Tue Jul 17, 2012 5:01 pm

Thankyou for your response.

In answer to your question, I have always used the Windows 7 Scheduler.
Since posting my original topic, I have deleted the Windows scheduler and performed 2 backups per day - all of which, again, ran perfectly. Again no errors, warnings.

I just setup the built-in scheduler. Then I ran it as a group. Again no errors or warnings.
I guess that your program is telling me to use its built-in scheduler and give up on using the Windows scheduler.

I'll set it up for a run tonight in the early morning hours with the built-in scheduler.
I'm betting this will solve the duplication of both differentials and fulls.

Post Reply