Cleanup job reports files deleted OK and removes them from catalog even though external HDD is not connected

Have questions about Backup4all, or having problems using it? Ask here for help.
Post Reply
Panos
Posts: 6
Joined: Sun Mar 27, 2011 11:56 pm

Cleanup job reports files deleted OK and removes them from catalog even though external HDD is not connected

Post by Panos » Mon Mar 28, 2011 12:52 am

I am currently running Backup4All Professional - version 4.5 Build 243 - on Vista 32-bit SP2. I have been running the B4A software since last summer.

I am backing up my files to an external hard drive. I have setup two Cleanup jobs to remove a) all files older than 8 weeks and b) all non-full backups older than 3 weeks. This way I have all backups for the last 3 weeks and only full backups for weeks 3-8.

As I move around, I occasionally leave the laptop disconnected from the external HDD and it may stay disconnected when the backup jobs start up. These particular backups fail but the files are correctly picked up next time the backup jobs run and the external HDD is connected again.

However, there is a problem with the cleanup jobs. Even when the external HDD is disconnected, they report the files as deleted and remove them from the backup catalog. As a result, they are NOT picked up next time the cleanup runs and I have to go in manually and remove them.

Here is an excerpt from a cleanup job log that reported success even though the external HDD was disconnected.

Code: Select all

[2011-03-26 07:30:00] Backup4all Professional Edition 4.5.243
[2011-03-26 07:30:00] Starting cleanup on "MyDocs" for backup numbers 356,357,358,359 at 2011-03-26 07:30:00
[2011-03-26 07:30:00] Deleting backup number: 356
[2011-03-26 07:30:00] Deleted file: "X:\Backups\MyDocs\MyDocs_2011-03-04_1600_Incr.356_C.zip" - OK
[2011-03-26 07:30:02] Deleted backup number 356 from catalog - OK
[2011-03-26 07:30:02] Deleting backup number: 357
[2011-03-26 07:30:02] Deleted file: "X:\Backups\MyDocs\MyDocs_2011-03-05_0300_Incr.357_C.zip" - OK
[2011-03-26 07:30:03] Deleted backup number 357 from catalog - OK
[2011-03-26 07:30:03] Deleting backup number: 358
[2011-03-26 07:30:03] Deleted file: "X:\Backups\MyDocs\MyDocs_2011-03-05_1600_Incr.358_C.zip" - OK
[2011-03-26 07:30:05] Deleted backup number 358 from catalog - OK
[2011-03-26 07:30:05] Deleting backup number: 359
[2011-03-26 07:30:05] Deleted file: "X:\Backups\MyDocs\MyDocs_2011-03-10_1600_Incr.359_C.zip" - OK
[2011-03-26 07:30:07] Deleted backup number 359 from catalog - OK

[2011-03-26 07:30:07] Saving backup catalog "C:\Users\User1\AppData\Roaming\Softland\Backup4all Professional 4\bkcFiles\MyDocs.bkc"
   Cleanup finished at 2011-03-26 07:30:15 with 0 error(s)
This is a bug and should be fixed.

If I may suggest - I think a better approach would be to apply the cleanup rule (e.g. anything > 8 weeks) to ALL backup files found in the backup directory, and not depend on the catalog view which may get out of sync with the directory (as described above) This directory should be managed by the backup software and the software should ensure the contents are consistent with the user cleanup rule. Users should not put any other files into those directories.

Thank you

Support
Posts: 1495
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Cleanup job reports files deleted OK and removes them from catalog even though external HDD is not connected

Post by Support » Wed Mar 30, 2011 9:48 am

Hi,

Thanks for reporting the bug.
We will fix this problem.

Post Reply