Change email settings

Have questions about Backup4all, or having problems using it? Ask here for help.
Post Reply
AnneW
Posts: 19
Joined: Sat Dec 06, 2014 12:04 pm

Change email settings

Post by AnneW » Sat Jun 18, 2016 10:08 am

Since my major reorganisation of my server (and simultaneous update of Backup4all) I find I am not getting emails signifying completion status. It was necessary to make large changes to my backup jobs, creating some new ones as well. I suspect that I have given the wrong credentials for sending emails, but can't find any way to change them. I need to send all details for successful smtp. How can I do this? Thanks.

Anne

AnneW
Posts: 19
Joined: Sat Dec 06, 2014 12:04 pm

Re: Change email settings

Post by AnneW » Tue Jun 21, 2016 3:34 pm

Here is a part of the log file, which I hope will show someone what my problem is:

Secure Channel Established.
Turning on TCP_NODELAY.
socketOptions:
SO_SNDBUF: 65536
SO_RCVBUF: 65536
TCP_NODELAY: 65537
--socketOptions
socketConnect: Elapsed time: 109 millisec
SmtpCmdResp: 220 smtp.<url removed>
initialResponse: Elapsed time: 16 millisec
SmtpCmdSent: EHLO Lenovo-PC
sendEhlo: Elapsed time: 0 millisec
SmtpCmdResp: 250-smtp.<url removed> at your service,
SmtpCmdResp: 250-SIZE 35882577
SmtpCmdResp: 250-8BITMIME
SmtpCmdResp: 250-AUTH LOGIN PLAIN XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER XOAUTH
SmtpCmdResp: 250-ENHANCEDSTATUSCODES
SmtpCmdResp: 250-PIPELINING
SmtpCmdResp: 250-CHUNKING
SmtpCmdResp: 250 SMTPUTF8
helloResponse: Elapsed time: 15 millisec
smtpAuthMethod: PLAIN
This SMTP server did not list authentication methods.
Defaulting to LOGIN authentication method.
login_method: LOGIN
auth_login_1:
SmtpCmdSent: AUTH LOGIN
SmtpCmdResp: 334 VXNlcm5hbWU6
SmtpCmdSent: Y2FubmV3aWxzb25AZ29vZ2xlbWFpbC5jb20=
SmtpCmdResp: 334 UGFzc3dvcmQ6
SmtpCmdSent: MjlPbGRDb2RnZXJz
SmtpCmdResp: 535-5.7.8 Username and Password not accepted. Learn more at
SmtpCmdResp: 535 5.7.8 https://support.google.com/mail/answer/14257 g3sm69310122wjb.47 - gsmtp
535 5.7.8 https://support.google.com/mail/answer/14257 g3sm69310122wjb.47 - gsmtp
Failed to get response to login password
--auth_login_1
Failed to login using LOGIN method
--SMTP_Connect
checkOrMakeSmtpConnection: Elapsed time: 328 millisec
--SmtpConnect
Failed.
--SendEmail
--ChilkatLog". (535)

GMail does use the login method I believe. I have confirmed the login details on Edge (which doesn't have any saved passwords) and the login completed successfully, so I can't see how Backup4All could be sending the wrong details. I did read the support article mentioned, but as far as I can see, none of the reasons given there are relevant to my problem. Any ideas?

Support
Posts: 1496
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Change email settings

Post by Support » Fri Jun 24, 2016 9:49 am

Hi,

Do you use 2-Step Verification for your Gmail account?
If you've turned on 2-Step Verification for your account, you might need to enter an App password instead of your regular password.

AnneW
Posts: 19
Joined: Sat Dec 06, 2014 12:04 pm

Re: Change email settings

Post by AnneW » Fri Jun 24, 2016 12:19 pm

No, it's not two-step verification. I'm not even clear which password I'm supposed to give. It seemed likely that it wanted the smtp.google password, but I've also tried my local user password. I can see from the logs that Backup4all is trying to send the emails, so it has to be my configuration of the communication that's wrong. I'd be grateful for any pointers. Thanks.

AnneW
Posts: 19
Joined: Sat Dec 06, 2014 12:04 pm

Re: Change email settings

Post by AnneW » Sun Jun 26, 2016 10:01 am

The error message says "SMTP server replied: ChilkatLog". Googling suggests that this means authentication is being attempted without security settings - and sure enough the logfile says

StartTLS: 0

I know that gmail will not accept messages without StartTLS set to !, so how can I change this?

Anne

Support
Posts: 1496
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Change email settings

Post by Support » Tue Jun 28, 2016 2:01 pm

Hi,

You must enter your Gmail login password.

AnneW
Posts: 19
Joined: Sat Dec 06, 2014 12:04 pm

Re: Change email settings

Post by AnneW » Sun Jul 03, 2016 9:29 am

Yes, that seemed the most likely, so it is what I have been doing.

Post Reply