cannot send email notifications through Microsoft Online hosted Exchange

Have questions about Backup4all, or having problems using it? Ask here for help.
Post Reply
Kremlar
Posts: 7
Joined: Mon Feb 14, 2011 6:14 pm

cannot send email notifications through Microsoft Online hosted Exchange

Post by Kremlar » Mon Feb 14, 2011 6:28 pm

We just migrated our email over to Microsoft Online (hosted Exchange). Trying to reconfigure notifications but the test email is not going out.

Our previous email provider used an unsecure SMTP at port 25. Microsoft Online uses TLS/SSL at port 587.

We are using:
Server: smtp.mail.microsoftonline.com
Port: 587
Use SSL: checked
From: (our email address)
Reply To: (our email address)
Server Requires Authentication: checked
Username: (our email address)
Password: (our password)

These settings work fine in Outlook 2007 and Outlook Express, but a test through Backup4all gives the following error:

Invalid token:
scRet: 80090308

Here is a screenshot of the actual error dialog:

Image

Any help would be greatly appreciated!

Support
Posts: 1471
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: cannot send email notifications through Microsoft Online hosted Exchange

Post by Support » Tue Feb 15, 2011 12:19 pm

Hi,

Please try using GMail.
Use these settings:
1. At Name/IP -> smtp.gmail.com
2. Port: 587 or 465
3. Set (check) the SSL option
4. Please set (check) the Authentication option
5. At username write your email address username@gmail.com
6. Password: your gmail password
7. At Email Address->From-> Please enter your email address username@gmail.com
8. You can send a test email.

Do you have the same problem?

Kremlar
Posts: 7
Joined: Mon Feb 14, 2011 6:14 pm

Re: cannot send email notifications through Microsoft Online hosted Exchange

Post by Kremlar » Thu Feb 17, 2011 7:42 pm

Gmail works with those settings at port 465, but NOT at port 587.

I would like to get this working with our Microsoft Online account if possible.

Any further suggestions?

Support
Posts: 1471
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: cannot send email notifications through Microsoft Online hosted Exchange

Post by Support » Fri Feb 18, 2011 9:43 am

Hi,

If you got GMail working that means the problem is not with Backup4all but with the settings you use for smtp.
Please make sure you used the correct settings.
You can try using port 465 for your configuration too.

Kremlar
Posts: 7
Joined: Mon Feb 14, 2011 6:14 pm

Re: cannot send email notifications through Microsoft Online hosted Exchange

Post by Kremlar » Mon Feb 21, 2011 9:02 pm

Port 465 will not work as Microsoft Online only allows port 587.

I believe the fact that Outlook works with the same settings proves that my settings are correct and that the problem lies with Backup4all.

Since Backup4all worked for us with our previous email provider and also with gmail I can only conclude that there is some compatibility issue between Backup4all and Microsoft Online (Exchange 2007) when using SSL.

We would like a resolution to this if possible as using gmail is not a reasonable solution for us or our other clients using Backup4all. We plan on migrating other Backup4all users to Microsoft Online in the near future.

Is there any chance of this being fixed in an upcoming build?

Support
Posts: 1471
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: cannot send email notifications through Microsoft Online hosted Exchange

Post by Support » Wed Feb 23, 2011 4:52 pm

Hi,

Can you provide us a temporary email account to see here what the problem is? Send the details to support[at]backup4all[dot]com

bensimon_1981
Posts: 1
Joined: Fri Apr 06, 2012 9:59 am

Re: cannot send email notifications through Microsoft Online hosted Exchange

Post by bensimon_1981 » Fri Apr 06, 2012 10:00 am

thanks for the information. i will get back for detailed explanation

rhaanappel
Posts: 1
Joined: Mon Oct 22, 2012 7:08 am

Re: cannot send email notifications through Microsoft Online hosted Exchange

Post by rhaanappel » Mon Oct 22, 2012 7:26 am

Was this issue ever resolved for the user?
Backup4All version 3 (v3.11) doesn't have a problem with sending emails through Office 365 but version 4 (4.8) does.
I believe the cause can be seen in the error message. "trying_auth_method: LOGIN"
Office 365 only supports SMTP relay authentication using TLS. Is there a Chilkat config file that can be edited to change settings to support TLS authentication? I ask this because I notice you seem to be using Chilkat embedded in your software.

Regards, Rod Haanappel

Support
Posts: 1471
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: cannot send email notifications through Microsoft Online hosted Exchange

Post by Support » Mon Oct 22, 2012 10:41 am

Hi,

The problem is not with Backup4all, users usually find the problem on their side or we help them to find the problem.
Usually the settings are not correct.

Have you tried sending emails using GMail settings as posted above?

Support
Posts: 1471
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: cannot send email notifications through Microsoft Online hosted Exchange

Post by Support » Thu Jul 18, 2013 8:04 am

Hi,

In version 4.9.291 of Backup4all Professional, we added the TLS option in Tools->Options->Email.

Post Reply