Backup won't run unless "user is logged in" is selected in Task Scheduler

Have questions about Backup4all, or having problems using it? Ask here for help.
Post Reply
mjcatt
Posts: 4
Joined: Wed Jun 21, 2017 2:09 pm

Backup won't run unless "user is logged in" is selected in Task Scheduler

Post by mjcatt »

I'm trying to create a schedule to backup a tag group with the requirement that the user does not have to be logged in. The task I created to do this fails to run. Does anyone have any insight into what is going on and how to fix it? I would hate to have to operate under the constraint that the user has to be explicitly logged in to run the backup task. Any help would be greatly appreciated!

I'm using Backup4all version 8.9 under Windows 11 HOME and I have three jobs tagged as "OnlineBackup". Two jobs with this tag access local drives only and one job accesses a network-attached drive.

For troubleshooting I'm just using the "run" button in Task Scheduler right now to (try to) execute my task immediately (I'm not worried about creating a schedule yet).

My Task Scheduler action is:
"c:\Program Files (x86)\Softland\Backup4all 8\btagbackup.exe" OnlineBackup -Priority 2

For troubleshooting purposes I have tried three cases as follow:

:arrow: CASE 1: run only when user is logged in
With the following Task Scheduler options, the task runs without errors and all tagged jobs run.
A local administrator account is specified
"Run only when user is logged in" is SELECTED
"Run with highest priority" is CHECKED

:arrow: CASE 2: run whether or not user is logged in, but no password stored
With the following Task Scheduler options, the tagged jobs accessing local resources run but a job that accesses network-attached resources fails (resources not found):
A local administrator account is specified
"Run whether the user is logged on or not" is SELECTED
"Do not store password" is CHECKED (account login credentials are not requested)
"Run with highest priority" is CHECKED

:arrow: CASE 3: run whether or not user is logged in; password is stored
With the following Task Scheduler options, the task fails to run
A local administrator account is specified
"Run whether the user is logged in or not" is SELECTED
"Do not store password" is UNCHECKED (and the administrator password is supplied)
"Run with highest priority" is CHECKED

I'll note in the failed CASE 3 that the task return code was 2147942401, which is unofficially recognized as "illegal function" or "incorrect function" and based on some searches I've tried adjusting some of the local security policies for user rights assignments (particularly "log on as a batch job") to include my administrator account, but this has not helped.

Adrian (Softland)
Posts: 1901
Joined: Wed Dec 16, 2009 12:46 pm

Re: Backup won't run unless "user is logged in" is selected in Task Scheduler

Post by Adrian (Softland) »

Hi,

For Case 2: if you map the network drive and use the mapped drive in your backup sources, are those files backed up?

For Case 3: is there any log created in the Logs folder at the scheduler execution time? If yes, please send us that log to support[at]backup4all[dot]com
Do you know you can monitor your backups remotely with Backup4all Monitor? You can read more here: https://www.backup4all.com/backup4all-monitor.html

mjcatt
Posts: 4
Joined: Wed Jun 21, 2017 2:09 pm

Re: Backup won't run unless "user is logged in" is selected in Task Scheduler

Post by mjcatt »

For case 2 I have two drives on Nvidia Shield TV pro mapped in windows as Y: and Z:. I can browse these drives in windows explorer but it is these two mapped drives that lead to task failure in Task Scheduler. Note however that the backup job in Backup4all (tag job) runs without errors when started manually in the Backup4all UI.

For case 3, I am sending the log entries to Backup4all support as suggested together with an xml export of the Task Scheduler task. The task is specified to run under user "admin", which is a local administrator account.

Adrian (Softland)
Posts: 1901
Joined: Wed Dec 16, 2009 12:46 pm

Re: Backup won't run unless "user is logged in" is selected in Task Scheduler

Post by Adrian (Softland) »

Hi,

For Case 2, is there any difference if you uncheck this option?
"Run with highest priority"

For Case 3 we are waiting for the email with the correct log file.
Do you know you can monitor your backups remotely with Backup4all Monitor? You can read more here: https://www.backup4all.com/backup4all-monitor.html

Post Reply