Backup4Aall Monitor 1 - Service keeps hanging

Have questions about Backup4all, or having problems using it? Ask here for help.
Post Reply
DaveP
Posts: 6
Joined: Tue Sep 12, 2017 12:00 pm

Backup4Aall Monitor 1 - Service keeps hanging

Post by DaveP » Fri Aug 02, 2019 12:50 pm

Hi,

I am running the 1.0.198 release of the monitor with B4A 8.1.202 on Windows 10 Home build 1903. I keep experiencing the monitor service hanging in a state where it cannot log events. This is happening intermittently after one or sometimes more backups.

Once in the hung state:
- Monitor test from B4A succeeds
- B4A cannot log monitoring events
- Monitor Client keeps trying to connect to service without success
- Windows Services control panel reports service running but Stop/Restart hangs
- I can only get the monitor to work again by rebooting.

I have tried uninstalling and re-installing the monitor but that changed nothing.

The backup process logs:

[02/08/2019 08:30:03] Detecting remote monitor having instance name Backup4allMonitoringSrv_DELIA
....
Backup completed in 6:53 minute(s) at 02/08/2019 08:36:56 with 0 error(s), 24 warning(s)
[02/08/2019 08:37:14] Failed to send action start info to remote monitor Error receiving data: (12002) The operation timed out
[02/08/2019 08:38:14] Failed to send action start info to remote monitor Error receiving data: (12002) The operation timed out
[02/08/2019 08:39:14] Failed to send action start info to remote monitor Error receiving data: (12002) The operation timed out
[02/08/2019 08:40:14] Failed to send action start info to remote monitor Error receiving data: (12002) The operation timed out
[02/08/2019 08:41:14] Failed to send action start info to remote monitor Error receiving data: (12002) The operation timed out
[02/08/2019 08:42:14] Failed to send action start info to remote monitor Error receiving data: (12002) The operation timed out

Any ideas/suggestions please?

Thanks

Dave

vc777
Posts: 1
Joined: Wed Aug 07, 2019 6:02 am

Re: Backup4Aall Monitor 1 - Service keeps hanging

Post by vc777 » Wed Aug 07, 2019 6:34 am

I have a similar issue, DaveP

I had also been running version 1.0.198 of the monitor, and had been successfully monitoring 2 installations of B4A for about 4 weeks on the trial licence. It's probably coincidence, but I purchased 3 licenses for the monitor, applied them successfully, and an hour or two after I started monitoring a third B4A instance the client started to hang when I refreshed or changed tabs. When I stopped the client and restarted it it only showed me the backup in progress and all history appeared to have disappeared.

I had all of the same symptoms as you listed once in the hung state, but even after a reboot, the client would start but hang when I tried to refresh or change tabs. I also tried an uninstall/reinstall. Now, my client can scan for and see the server, but regardless of whether I try to connect by instance name or URL address (IP/Port), it just gets stuck on the "Connecting to" window, so I don't even get to the main application screen. I can browse to the server on 127.0.0.1:9502 without any trouble.

My backup logs are a little different to yours:

[7/08/2019 7:41:27 AM] Failed to send action start info to remote monitor The handle is in the wrong state for the requested operation - URL:http://127.0.0.1:9502/Backup4allMonitoringSrv_MINE/Soap - SOAPAction:http://tempuri.org/MonitoringServiceContract/Start

Anyway, here's hoping for an easy solution! :)

Alan

administrator
Site Admin
Posts: 1
Joined: Thu May 12, 2011 8:46 am

Re: Backup4Aall Monitor 1 - Service keeps hanging

Post by administrator » Thu Aug 08, 2019 4:27 pm

A quick (temporary fix) would be to restart “Backup4all Monitoring Srv” service from Control Panel.
I guess this service has somehow hanged.

Restart monitoring client and try to connect.
Does it work?


Daniel

DaveP
Posts: 6
Joined: Tue Sep 12, 2017 12:00 pm

Re: Backup4Aall Monitor 1 - Service keeps hanging

Post by DaveP » Thu Aug 08, 2019 8:52 pm

Hi Daniel,

Thank you but as I reported in my post I have tried that. If I attempt to stop or restart the service from the windows services panel it just hangs in a 'Stopping' or 'Restarting' state and remains there until I reboot. After reboot I get one or two backups before the service hangs again.

Any more suggestions please?

Dave

Softland
Posts: 49
Joined: Wed Dec 16, 2009 10:48 am
Location: Cluj-Napoca, Romania
Contact:

Re: Backup4Aall Monitor 1 - Service keeps hanging

Post by Softland » Mon Aug 12, 2019 12:39 pm

Please install the latest version of the Monitor which is 1.0.210.

Post Reply