Page 1 of 1

ChilkatLog sending email error.

Posted: Sun Apr 30, 2017 8:06 pm
by danico
When I do a test of email it works great but when I run the job the email does not send. I've tested with and without the backup log attachment and it makes no difference. I have several other customers I have configured the exact same way, the same firewalls, same antivirus, same email account (on gmail) with not issues.

Here is the log, if someone could give me anidea where to go from here I would appreciate the help.

Thanks everyone.

[4/29/2017 8:28:46 PM] Cannot send the email message. The SMTP server replied: "ChilkatLog:
DllDate: Dec 12 2012
UnlockPrefix: CSoftlandMAILQ
Username: servername:Administrator
Architecture: Little Endian; 32-bit
Language: Visual C++ 10.0
VerboseLogging: 0
totalCount: 1
xSigningAlg: sha1
Auto-generating Message-ID
renderToMime: Elapsed time: 0 millisec
SmtpPort: 587
SmtpUsername: dsbackup@gmail
SmtpSsl: 0
StartTLS: 1
SmtpAuthMethod: PLAIN
Need new SMTP connection
checkForExistingConnection: Elapsed time: 0 millisec
Connecting to SMTP server
smtp_port: 587
auth-method: PLAIN
ConnectTimeoutMs_1: 30000
calling ConnectSocket2
IPV6 enabled connect with NO heartbeat.
GetHostByNameHB_ipv4: Elapsed time: 0 millisec
sockError: 10107
Connect function failed.
SocketError: Error 0x277b
Check to make sure the connection is not blocked by a firewall or anti-virus port filtering.
Failed to connect to SMTP server.
checkOrMakeSmtpConnection: Elapsed time: 0 millisec
--ChilkatLog". (0)

Re: ChilkatLog sending email error.

Posted: Wed May 03, 2017 12:39 pm
by Support

Please use the following settings for SMTP:
1. At Name/IP ->
2. Port: 587 or 465
3. Set (check) the SSL option
4. Please set (check) the Authentication option
5. At username write your email address
6. Password: your gmail password
7. At Email Address->From-> Please enter your email address
8. You can send a test email.

Re: ChilkatLog sending email error.

Posted: Sun May 21, 2017 6:03 pm
by danico
I don't think you read the post. All of this is fine, when I run a test it runs fine. If I run the backup the email works fine. When a scheduled backup runs, the email fails. I've turned off all firewalls and tested everything I can think of. Still, a scheduled job does not send the email, only manual tests work.

Re: ChilkatLog sending email error.

Posted: Mon May 22, 2017 10:58 am
by Support

I did read your post. I responded you based on the information you provided. You forgot to tell us the problem exists only if the job was scheduled.
Only in your second post, you mentioned the email works when you manually execute the backup.

Please let us know: is there any user logged on at the scheduled time? If not, please try to run a scheduled backup when there is at least one user logged on. Does it makes a difference?
Send us the complete backup log to support[at]backup4all[dot]com