Access Denied (5)

Have questions about Backup4all, or having problems using it? Ask here for help.
vcmed_mm
Posts: 4
Joined: Tue Feb 07, 2017 9:56 am

Access Denied (5)

Postby vcmed_mm » Tue Feb 07, 2017 10:09 am

The software gives us the opportunity to run a batch script after the backup process is finished. At the end of that batch script we are using a shutdown command (shutdown -s) which won’t be executed and the „error“-output is „access denied (5)“. Even with administrator permissions we are encountering this issue.

When we use the script without „backup4all professional 6“ or just type shutdown -s in the command line, the computer will shut down immediately without the „access denied“ notification.

The computer is connected to a windows domain network.
OS: Windows 7
Backup4All Version: 6.4.311
Shutdown Command: shutdown -s

Can you give us any tips to solve this issue?

Support
Posts: 1288
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Access Denied (5)

Postby Support » Wed Feb 08, 2017 7:15 am

Hi,

Please right-click the batch file and go to Properties->Compatibility, then select the option to run as administrator.
Do you still have the problem?

vcmed_mm
Posts: 4
Joined: Tue Feb 07, 2017 9:56 am

Re: Access Denied (5)

Postby vcmed_mm » Wed Feb 08, 2017 10:56 am

Thank you for your reply.

Due to security reasons, the user shouldn't be allowed to run the batch script as an administrator or even know the password for authentication.

After clicking through the backup properties, I've found the "schedule"-option "At system shutdown". That means the backup task will run at system shutdown and that's exactly what we need. The first test was fine and everything was executed correctly. After deleting the existing backup task and creating another one with the same name, a warning occurred after executing the task at system shutdown. The warning output was "invalid parameters. Parameter {the long Backup-ID} is not a valid backup job or group". I compared the backup-id in the warning output with the backup-id of our existing task and they aren't equal. Is there a file where all "tasks at system shut down" are saved or where does the software save this information?

Support
Posts: 1288
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Access Denied (5)

Postby Support » Fri Feb 10, 2017 1:18 pm

Hi,

It seems the scheduled task remained in Control Panel->Administrative Tools->Task Scheduler.
Make sure you delete that invalid task.

vcmed_mm
Posts: 4
Joined: Tue Feb 07, 2017 9:56 am

Re: Access Denied (5)

Postby vcmed_mm » Sun Feb 12, 2017 6:19 pm

Hi,

The task scheduler is empty.
Even when I create the backup task with the option "run at system shutdown", the task scheduler is still empty but backup4all is starting when I press shutdown. While the programm is starting, I receive that warning message with the wrong job ID.

Again:
When I create a backup job with "run at system shutdown" option -> Task Scheduler is empty -> Backup4all will start at shutdown anyway. It was no problem with the first job but after deleting my first job and creating a new one with the same options --> warning with a wrong job ID (the job ID in this warning message is the one of my first test job I guess)

Support
Posts: 1288
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Access Denied (5)

Postby Support » Tue Feb 14, 2017 12:34 pm

Hi,

Please also look in C:\Windows\Tasks
Are there any scheduled tasks?

vcmed_mm
Posts: 4
Joined: Tue Feb 07, 2017 9:56 am

Re: Access Denied (5)

Postby vcmed_mm » Tue Feb 14, 2017 3:31 pm

This folder is also empty. There are no files which are related to backup4all

Support
Posts: 1288
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Access Denied (5)

Postby Support » Wed Feb 15, 2017 12:39 pm

Hi,

Can you give me access to your computer using TeamViewer?
Please send us an email to support[at]backup4all[dot]com, to discuss when you are available.


Return to “Support & Troubleshooting”